summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-19 10:35:52 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:56 +0200
commitf0a4158583014ab0e8c47db7094352786f476ebb (patch)
tree2c80f10fae4285d6cc4538e134db03760b9da18c
parent8dee127458349c069aa3270e06dc96dd96881e86 (diff)
downloadguix-f0a4158583014ab0e8c47db7094352786f476ebb.tar.gz
gnu: Add rust-precomputed-hash-0.1.
* gnu/packages/crates-io.scm (rust-precomputed-hash-0.1): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5230dbda69..8dd8a78a75 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6701,6 +6701,30 @@ for x86.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-precomputed-hash-0.1
+  (package
+    (name "rust-precomputed-hash")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "precomputed-hash" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "075k9bfy39jhs53cb2fpb9klfakx2glxnf28zdw08ws6lgpq6lwj"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page
+     "https://github.com/emilio/precomputed-hash")
+    (synopsis
+     "Base dependency to expose a precomputed hash")
+    (description
+     "This package provides a library intending to be a base
+dependency to expose a precomputed hash.")
+    (license license:expat)))
+
 ;; Cyclic dependencies with rust-demo-hack.
 (define-public rust-proc-macro-hack-0.5
   (package