summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 23:58:33 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:35:30 +0100
commitf0e5d0b411f1465e11058eb40eac467e75bd8d81 (patch)
treefa61cef986ec760579a7cc4735dd403f9f26075f
parent5978962638072ab7720fb08918e6eab80e6a1f26 (diff)
downloadguix-f0e5d0b411f1465e11058eb40eac467e75bd8d81.tar.gz
gnu: go-github-com-go-ldap-ldap: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-go-ldap-ldap): Move from
here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: Ica9883664d11b621d0bd4ce896d217eb82abd0ce
-rw-r--r--gnu/packages/golang-web.scm27
-rw-r--r--gnu/packages/syncthing.scm25
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a2647788eb..13074eb851 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -789,6 +789,33 @@ Signing and Encryption set of standards.  This includes support for JSON Web
 Encryption, JSON Web Signature, and JSON Web Token standards.")
     (license license:asl2.0)))
 
+(define-public go-github-com-go-ldap-ldap
+  (package
+    (name "go-github-com-go-ldap-ldap")
+    (version "3.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/go-ldap/ldap")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xf2jrwhgr06jy4liba48hrz4b7j27r7m9dnl7fj95vazsx2n5br"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:tests? #f ; test suite requires internet access
+      #:import-path "github.com/go-ldap/ldap/v3"))
+    (propagated-inputs
+     (list go-github-com-go-asn1-ber-asn1-ber
+           go-github-com-azure-go-ntlmssp))
+    (home-page "https://github.com/go-ldap/ldap")
+    (synopsis "LDAP v3 functionality for Go")
+    (description "This package provides basic LDAP v3 functionality in the Go
+language.")
+    (license license:expat)))
+
 (define-public go-github-com-go-telegram-bot-api-telegram-bot-api
   (package
     (name "go-github-com-go-telegram-bot-api-telegram-bot-api")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0700f1a258..4dbbfe1131 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -491,31 +491,6 @@ message streaming.")
     (home-page "https://github.com/matttproud/golang_protobuf_extensions")
     (license asl2.0)))
 
-(define-public go-github-com-go-ldap-ldap
-  (package
-    (name "go-github-com-go-ldap-ldap")
-    (version "3.4.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/go-ldap/ldap")
-                     (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32 "1xf2jrwhgr06jy4liba48hrz4b7j27r7m9dnl7fj95vazsx2n5br"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/go-ldap/ldap/v3"
-       #:tests? #f)) ; test suite requires internet access
-    (propagated-inputs
-     (list go-github-com-go-asn1-ber-asn1-ber
-           go-github-com-azure-go-ntlmssp))
-    (home-page "https://github.com/go-ldap/ldap")
-    (synopsis "LDAP v3 functionality for Go")
-    (description "This package provides basic LDAP v3 functionality in the Go
-language.")
-    (license expat)))
-
 (define-public go-github-com-flynn-archive-go-shlex
   (let ((commit "3f9db97f856818214da2e1057f8ad84803971cff")
         (revision "0"))