summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2020-09-02 13:44:12 -0400
committerTimothy Sample <samplet@ngyro.com>2020-09-02 13:44:12 -0400
commitf14e808aeae7b2fa7536f5fe62dae66b788fea84 (patch)
tree9be69cd0764783bdd769e54839620fc83b55a964
parent4f9043c6eca5a9b32d2be633adc11ceed87faa49 (diff)
downloadguix-f14e808aeae7b2fa7536f5fe62dae66b788fea84.tar.gz
gnu: hedgewars: Fix build with shared libraries.
Fixes: <https://bugs.gnu.org/43112>.

* gnu/packages/games.scm (hedgewars)[arguments]: Set "haskell_flags"
in #:configure-flags to enable dynamic linking.
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 479ae52ab0..1cd0df0dd0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8848,7 +8848,8 @@ play with up to four players simultaneously.  It has network support.")
      ;; XXX: Engine is built as Pascal source code, requiring Free Pascal
      ;; Compiler, which we haven't packaged yet.  With the flag below, we use
      ;; a Pascal to C translator and Clang instead.
-     `(#:configure-flags (list "-DBUILD_ENGINE_C=ON")
+     `(#:configure-flags (list "-DBUILD_ENGINE_C=ON"
+                               "-Dhaskell_flags=-dynamic;-fPIC")
        #:phases
        (modify-phases %standard-phases
          (replace 'check