summary refs log tree commit diff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-23 23:21:14 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-10-24 14:39:43 +0300
commitf15bfd49e68001f450a0198140dc422e15e2e4e5 (patch)
treed669cd6159f3698d0d293a7f269adb1d93b53f3e
parent3a0b15b829cae87b695f5bf011a25d232514b6a0 (diff)
downloadguix-f15bfd49e68001f450a0198140dc422e15e2e4e5.tar.gz
gnu: Add rust-gstreamer-0.18.
* gnu/packages/crates-gtk.scm (rust-gstreamer-0.18): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Change-Id: I55a2acaa97d5bc74c3adf48bfafb96b9d67d20c0
-rw-r--r--gnu/packages/crates-gtk.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 90e8c1a6b7..7911e9c167 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1711,6 +1711,50 @@
        (("rust-shell-words" ,rust-shell-words-0.1)
         ("rust-tempfile" ,rust-tempfile-3))))))
 
+(define-public rust-gstreamer-0.18
+  (package
+    (name "rust-gstreamer")
+    (version "0.18.8")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "gstreamer" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0mjlnw9917j3wwij8225bjp54k7408lxqjjnh6r6wksyryx66qyn"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:tests? #f  ; https://github.com/gtk-rs/gtk3-rs/issues/768
+           #:cargo-inputs `(("rust-bitflags" ,rust-bitflags-1)
+                            ("rust-cfg-if" ,rust-cfg-if-1)
+                            ("rust-futures-channel" ,rust-futures-channel-0.3)
+                            ("rust-futures-core" ,rust-futures-core-0.3)
+                            ("rust-futures-util" ,rust-futures-util-0.3)
+                            ("rust-glib" ,rust-glib-0.15)
+                            ("rust-gstreamer-sys" ,rust-gstreamer-sys-0.18)
+                            ("rust-libc" ,rust-libc-0.2)
+                            ("rust-muldiv" ,rust-muldiv-1)
+                            ("rust-num-integer" ,rust-num-integer-0.1)
+                            ("rust-num-rational" ,rust-num-rational-0.4)
+                            ("rust-once-cell" ,rust-once-cell-1)
+                            ("rust-option-operations" ,rust-option-operations-0.4)
+                            ("rust-paste" ,rust-paste-1)
+                            ("rust-pretty-hex" ,rust-pretty-hex-0.3)
+                            ("rust-serde" ,rust-serde-1)
+                            ("rust-serde-bytes" ,rust-serde-bytes-0.11)
+                            ("rust-thiserror" ,rust-thiserror-1))
+           #:cargo-development-inputs
+            `(("rust-futures-executor" ,rust-futures-executor-0.3)
+              ("rust-gir-format-check" ,rust-gir-format-check-0.1)
+              ("rust-ron" ,rust-ron-0.7)
+              ("rust-serde-json" ,rust-serde-json-1))))
+    (native-inputs (list pkg-config))
+    (inputs (list glib gstreamer))
+    (home-page "https://gstreamer.freedesktop.org")
+    (synopsis "Rust bindings for GStreamer")
+    (description "Rust bindings for GStreamer.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gstreamer-sys-0.18
   (package
     (name "rust-gstreamer-sys")