summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:09:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:54 +0100
commitf18c0544f6dd48aee582d95a0d6400939fa8b441 (patch)
tree77c1c6bd3ab62115f99980da09186c8db1d3838c
parent56cba940c3e56d0c811652e638408d098894ae8e (diff)
downloadguix-f18c0544f6dd48aee582d95a0d6400939fa8b441.tar.gz
gnu: Add r-ada.
* gnu/packages/cran.scm (r-ada): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d09bc22e19..d7b8e866d6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17476,3 +17476,27 @@ unit.\" @url{doi:10.1371/journal.pone.0174623}")
 autoregressive properties, using the @dfn{Autoregressive Conditional Poisson}
 model (ACP(p,q)) proposed by Heinen (2003).")
     (license license:gpl2)))
+
+(define-public r-ada
+  (package
+    (name "r-ada")
+    (version "2.0-5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ada" version))
+       (sha256
+        (base32
+         "1h3a07czp0w3hrhjcg1fz721y8vsfclzqi3rq8qfzgpfb4h1f06r"))))
+    (properties `((upstream-name . "ada")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rpart" ,r-rpart)))
+    (home-page "https://cran.r-project.org/web/packages/ada/")
+    (synopsis "Stochastic boosting")
+    (description
+     "This package provides a straightforward, well-documented, and broad
+boosting routine for classification, ideally suited for small to
+moderate-sized data sets.  It performs discrete, real, and gentle boost under
+both exponential and logistic loss on a given data set.")
+    ;; Any version of the GPL.
+    (license (list license:gpl2+ license:gpl3+))))