summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 17:28:10 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:09:00 +0200
commitf1ec4d761122f68a5fb42d5ddaf6a626b6f7837d (patch)
tree161ed889ccd41ef5b0097da067fb6a83b3ca6a89
parentf8ae2ee528be1b9d92a61b6dc6b470821e645afd (diff)
downloadguix-f1ec4d761122f68a5fb42d5ddaf6a626b6f7837d.tar.gz
gnu: Add ruby-mercenary.
* gnu/packages/ruby.scm (ruby-mercenary): New variable.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3f0cfcfcfa..4947e1b43b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5788,3 +5788,23 @@ indentation will probably be an issue and hence this gem.")
     (description "The SafeYAML gem provides an alternative implementation of
 YAML.load suitable for accepting user input in Ruby applications.")
     (license license:expat)))
+
+(define-public ruby-mercenary
+  (package
+    (name "ruby-mercenary")
+    (version "0.3.6")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "mercenary" version))
+              (sha256
+               (base32
+                "10la0xw82dh5mqab8bl0dk21zld63cqxb1g16fk8cb39ylc4n21a"))))
+    (build-system ruby-build-system)
+    (arguments `(#:test-target "spec"))
+    (native-inputs
+     `(("bundler" ,bundler)))
+    (home-page "https://github.com/jekyll/mercenary")
+    (synopsis "Command-line apps library in Ruby")
+    (description "Mercenary is a lightweight and flexible library for writing
+command-line apps in Ruby.")
+    (license license:expat)))