summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-05 14:04:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-05 15:10:33 +0200
commitf2561811fb1c2955509b8417fd341ec2e62e7ee8 (patch)
treeb2c870b3c1192ee7a8c8aabf53420c56188d9f4e
parent7b4623b44b051a520ff4fe1c46bb74f2f4f4a492 (diff)
downloadguix-f2561811fb1c2955509b8417fd341ec2e62e7ee8.tar.gz
gnu: python-schedule: Adjust for newer python.
* gnu/packages/python-xyz.scm (python-schedule)[source]: Add snippet to
adjust python imports.

Change-Id: I8ef362bd35d3d1a2634a16ee4bf790b7da8263c0
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 28be393f0a..f54a9b0f88 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3675,7 +3675,12 @@ in the current session, Python, and the OS.")
       (uri (pypi-uri "schedule" version))
       (sha256
        (base32
-        "0vplyjcbfrq50sphlwya749z8p2pcyi2nycw3518i0qpd9a6189i"))))
+        "0vplyjcbfrq50sphlwya749z8p2pcyi2nycw3518i0qpd9a6189i"))
+      (snippet
+       #~(begin (use-modules (guix build utils))
+                (substitute* "schedule/__init__.py"
+                  (("collections\\.Hashable")
+                   "collections.abc.Hashable"))))))
     (build-system python-build-system)
     (native-inputs
      (list python-pytest python-mock))