summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:24:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:17 +0200
commitf33a009aad0d0f65b3b287bb695052e3692e0a1f (patch)
tree8d3f14763f0639a3b0b890de2ca17f99bc941066
parentd8596850c08c6df31a02d0fe036a95162edec728 (diff)
downloadguix-f33a009aad0d0f65b3b287bb695052e3692e0a1f.tar.gz
gnu: Add texlive-plain-doc.
* gnu/packages/tex.scm (texlive-plain-doc): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d9599692aa..f22e7e0153 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13885,6 +13885,26 @@ using TikZ.")
 arts.")
     (license license:lppl1.3c)))
 
+(define-public texlive-plain-doc
+  (package
+    (name "texlive-plain-doc")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/plain-doc/")
+             (base32
+              "062d6hg4npy57307avvyd2sdxnmyrh5ia2rdb17p6cx555k8zxwq")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/csname-doc")
+    (synopsis "List of Plain TeX control sequence names")
+    (description
+     "The document constitutes a list of every control sequence
+name (@dfn{csname}) described in the TeXbook, together with an indication of
+whether the csname is a primitive TeX command, or is defined in
+@file{plain.tex}.")
+    (license license:public-domain)))
+
 (define-public texlive-pmgraph
   (package
     (name "texlive-pmgraph")