summary refs log tree commit diff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-11-29 07:01:03 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:08 +0100
commitf3b85cc10c2ec9d0833699755836670b05cf810f (patch)
treea2bb858b6dd907967522b985922afe94ac82667a
parent8abe78a890d7b21f064bf9782a0ba25b7bf526ed (diff)
downloadguix-f3b85cc10c2ec9d0833699755836670b05cf810f.tar.gz
gnu: rust-which-4: Update to 4.3.0.
* gnu/packages/crates-io.scm (rust-which-4): Update to 4.3.0.
[synopsis, description]: Improve.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cf9bd5f850..00d141e100 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66304,27 +66304,28 @@ using @code{bindgen}.")
 (define-public rust-which-4
   (package
     (name "rust-which")
-    (version "4.2.2")
+    (version "4.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "which" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1nbsy9f5sn206jzby28if4m4s0m21n97mhk8qd703g3rya77l67a"))))
+        (base32 "0yybp94wikf21vkcl8b6w6l5pnd95nl4fxryz669l4lyxsxiz0qw"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-either" ,rust-either-1)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-libc" ,rust-libc-0.2)
-        ("rust-regex" ,rust-regex-1))))
+     (list #:skip-build? #t
+           #:cargo-inputs
+           `(("rust-either" ,rust-either-1)
+             ("rust-libc" ,rust-libc-0.2)
+             ("rust-once-cell" ,rust-once-cell-1)
+             ("rust-regex" ,rust-regex-1))))
     (home-page "https://github.com/harryfei/which-rs.git")
-    (synopsis "Rust equivalent of Unix command @command{which}")
+    (synopsis "Rust equivalent of @command{which}")
     (description
-     "This package provides a Rust equivalent of Unix command @command{which}.
-It locates installed executable in cross platforms.")
+     "This package provides a cross-platform Rust equivalent of the
+Unix @command{which} command.  It returns the full path of an installed
+executable.")
     (license license:expat)))
 
 (define-public rust-which-3