summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2014-12-15 12:36:10 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-16 18:17:15 +0100
commitf3cd952b45ea0bb788287fda03ebe796eb9461b8 (patch)
tree73df440b4532c1ce59ae523f85ae9920e7dafee3
parenta142e38e9dfb56761bd614a28022f9c1711bd8b7 (diff)
downloadguix-f3cd952b45ea0bb788287fda03ebe796eb9461b8.tar.gz
gnu: samtools: disable tests for non-64-bit systems
* gnu/packages/bioinformatics.scm (samtools): disable tests for all non-64-bit
  systems because of an upstream bug in the test data.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6f6178a3ff..7e802278ac 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -43,7 +43,14 @@
          "1y5p2hs4gif891b4ik20275a8xf3qrr1zh9wpysp4g8m0g1jckf2"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
+     `(;; There are 87 test failures when building on non-64-bit architectures
+       ;; due to invalid test data.  This has since been fixed upstream (see
+       ;; <https://github.com/samtools/samtools/pull/307>), but as there has
+       ;; not been a new release we disable the tests for all non-64-bit
+       ;; systems.
+       #:tests? ,(string=? (or (%current-system) (%current-target-system))
+                           "x86_64-linux")
+       #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
        #:phases
        (alist-cons-after
         'unpack