summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:28:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:52 +0200
commitf3e2b3da8fb5472d347276a2c13bde00583a9fee (patch)
treec0dcd9b7e04a01f6d63f025971bfc05e4206d582
parent235a3e622149dde7f6afbb4bbf26a8cca9eb806d (diff)
downloadguix-f3e2b3da8fb5472d347276a2c13bde00583a9fee.tar.gz
gnu: Add texlive-lpform.
* gnu/packages/tex.scm (texlive-lpform): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8f7b59dd57..1536610527 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4408,6 +4408,30 @@ or it encounters a repeated remainder. @code{\\intlongdivision} stops when the
 dividend stops (though the dividend doesn't have to be an integer).")
     (license license:lppl)))
 
+(define-public texlive-lpform
+  (package
+    (name "texlive-lpform")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/lpform/" "tex/generic/lpform/")
+             (base32
+              "13pg4wb3z8xhmf9wry4rvdzhg0ydhpbdp6vxjk7g91p6s3lvqa51")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lpform")
+    (synopsis
+     "Typesetting linear programming formulations and sets of equations")
+    (description
+     "The package is designed to aid the author writing linear programming
+formulations, one restriction at a time.  With the package, one can easily
+label equations, formulations can span multiple pages and several elements of
+the layout (such as spacing, texts and equation tags) are also customizable.
+Besides linear programming formulations, this package can also be used to
+display any series of aligned equations with easy labeling/referencing and
+other customization options.")
+    (license license:lppl)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")