summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-19 22:59:12 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-01-25 00:42:04 +0300
commitf48feaa2848d999e100f27301680a01dc3bd7733 (patch)
treefe967ec610e9828725c709c18530cd474af1793c
parentd32456d5a28ab5982030401ed830088f9d2e8fe4 (diff)
downloadguix-f48feaa2848d999e100f27301680a01dc3bd7733.tar.gz
gnu: Add streamlink.
* gnu/packages/video.scm (streamlink): New public variable.
-rw-r--r--gnu/packages/video.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e7285e50b5..d2599345d4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -89,6 +89,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages iso-codes)
   #:use-module (gnu packages libreoffice)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
@@ -102,6 +103,7 @@
   #:use-module (gnu packages popt)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages ruby)
@@ -1725,6 +1727,35 @@ from various services and pipes them into a video playing application.")
     (home-page "http://livestreamer.io/")
     (license license:bsd-2)))
 
+(define-public streamlink
+  (package
+    (name "streamlink")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "streamlink" version))
+       (sha256
+        (base32
+         "17299xnd9jzi7m1d2rr4xdlj47q64bzj2957nlsrhw0hskds1s6h"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/streamlink/streamlink")
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-mock" ,python-mock)
+       ("python-requests-mock" ,python-requests-mock)))
+    (propagated-inputs
+     `(("python-pysocks" ,python-pysocks)
+       ("python-websocket-client" ,python-websocket-client)
+       ("python-iso3166" ,python-iso3166)
+       ("python-iso639" ,python-iso639)
+       ("python-pycryptodome" ,python-pycryptodome)
+       ("python-requests" ,python-requests)))
+    (synopsis "Extract streams from various services")
+    (description "Streamlink is command-line utility that extracts streams
+from sites like Twitch.tv and pipes them into a video player of choice.")
+    (license license:bsd-2)))
+
 (define-public mlt
   (package
     (name "mlt")