summary refs log tree commit diff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-18 13:45:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:32 +0000
commitf5de1f96ed46c427b67d78304977884ff7165538 (patch)
treecd1439c98e8ebbf7020a97bfe1f45b1defd5f49e
parent4bbca060daf59622d027c874c9e9a2d715c286a7 (diff)
downloadguix-f5de1f96ed46c427b67d78304977884ff7165538.tar.gz
gnu: Add go-github-com-coocood-freecache.
* gnu/packages/golang-xyz.scm (go-github-com-coocood-freecache): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4e0c0e8a28..836357bb02 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -268,6 +268,33 @@ quantiles over an unbounded data stream within low memory and CPU bounds.")
 similar to Go's standard library @code{json} and @code{xml} package.")
     (license license:expat)))
 
+(define-public go-github-com-coocood-freecache
+  (package
+    (name "go-github-com-coocood-freecache")
+    (version "1.2.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/coocood/freecache")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0iw0s07qy8g1lncwl524c524wh56djl0vn6i3bm91cnwzav7ihjl"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/coocood/freecache"))
+    (propagated-inputs (list go-github-com-cespare-xxhash))
+    (home-page "https://github.com/coocood/freecache")
+    (synopsis "Caching library for Go")
+    (description
+     "This library provides caching capabilities for Go with no garbage
+collection overhead and high concurrent performance.  An unlimited number of
+objects can be cached in memory without increased latency or degraded
+throughput.")
+    (license license:expat)))
+
 (define-public go-github-com-coreos-go-systemd-activation
   (package
     (name "go-github-com-coreos-go-systemd-activation")