summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:05:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 05:41:18 +0100
commitf5e1a0e5767bc1e7baa9a116144fdded2f0c5648 (patch)
tree37b458ca6e490b05ba68d63b478297cab252730d
parent3e7b376e08ced847795d6434189d0b78c89a4173 (diff)
downloadguix-f5e1a0e5767bc1e7baa9a116144fdded2f0c5648.tar.gz
gnu: vkquake: Don't use unstable tarball.
* gnu/packages/games.scm (vkquake)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4636e228b6..8702dad302 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4957,13 +4957,13 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
     (version "1.01.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/Novum/vkQuake/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Novum/vkQuake.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0j8lh5by3pvjh6qr9piqlnq8mb5vv7sh0h3b9bqxlqm2ys0ap8hi"))))
+        (base32 "1iwin8j5kbyrknbkhjgpy8nmm7pxqzr0daa9gn7p38qhg2mh0a39"))))
     (arguments
      `(#:make-flags
        (let ((vulkanlib (string-append (assoc-ref %build-inputs