summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <contact@phfrohring.com>2022-08-07 13:43:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-08-25 14:08:42 +0200
commitf677f8b6dbea1e7d995d8f7f660c82ec19624db2 (patch)
treea4c47396515edbfdc0160e3fea5325dc89895d49
parent9593cf511e4ca12e0880fbcddc9b7ce3b5139598 (diff)
downloadguix-f677f8b6dbea1e7d995d8f7f660c82ec19624db2.tar.gz
gnu: Add emacs-vertico-posframe.
* gnu/packages/emacs-xyz.scm (emacs-vertico-posframe): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index aeb921d82c..f0163fe2f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32136,3 +32136,27 @@ projects.")
 tree to go back to previous buffer states.  To use vundo, type @kbd{M-x vundo RET} in
 the buffer you want to undo.  An undo tree buffer should pop up.")
     (license license:gpl3+)))
+
+(define-public emacs-vertico-posframe
+  (package
+    (name "emacs-vertico-posframe")
+    (version "0.5.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://elpa.gnu.org/packages/vertico-posframe-" version
+                    ".tar"))
+              (sha256
+               (base32
+                "19lx6p06wkwfivxgswdljdsh9bgcd1b9zkzx426w3pwicdk0cvgg"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-posframe emacs-vertico))
+    (home-page "https://github.com/tumashu/vertico-posframe")
+    (synopsis "Pop up a frame at point to show vertical completion UI")
+    (description
+     "Vertico is an Emacs package that provides a vertical completion UI based
+on the default completion system.  Posframe is an Emacs package that provides
+a way to pop up a frame at point.  Vertico-posframe is an Emacs package and
+a Vertico extension which provides a way to pop up a frame at point to show
+a vertical completion UI.")
+    (license license:gpl3+)))