summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:43:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:32 +0200
commitf765157a745f3fd76ea7807c88da9974169b548b (patch)
tree266baf68810bc3ac4ae6a4d1b832fe0f07a551b0
parent7e28e88e2b7b91c6cce132b1f8ae2d785891314a (diff)
downloadguix-f765157a745f3fd76ea7807c88da9974169b548b.tar.gz
gnu: Add texlive-gzt.
* gnu/packages/tex.scm (texlive-gzt): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1c4d8d9e68..3007054d59 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15534,6 +15534,31 @@ programs are provided as sources, not installed in the @file{bin}
 directories.")
     (license license:public-domain)))
 
+(define-public texlive-gzt
+  (package
+    (name "texlive-gzt")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/gzt/" "source/latex/gzt/"
+                   "tex/latex/gzt/")
+             (base32
+              "0gyiy9vzr760mkvaabd3aj3rgz60b9dhc7m5a2rnhzz5sz4a2yv3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/gzt")
+    (synopsis "Bundle of classes for @emph{La Gazette des Mathematiciens}")
+    (description
+     "This bundle provides two classes and BibLaTeX styles for the French
+journal @emph{La Gazette des Mathematiciens}: @code{gzt} for the complete
+issues of the journal, aimed at the Gazette's team, @code{gztarticle},
+intended for authors who wish to publish an article in the Gazette.  This
+class's goals are to faithfully reproduce the layout of the Gazette, thus
+enabling the authors to be able to work their document in actual conditions,
+and provide a number of tools (commands and environments) to facilitate the
+drafting of documents, in particular those containing mathematical formulas.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-hacm
   (package
     (name "texlive-hacm")