summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-20 11:23:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-03-20 18:27:45 +0200
commitf80215c7c4ae5ea0c316f4766e6c05ae4218ede3 (patch)
treed684c5914b55dd627832b077bee3ac1b32741e67
parentf541989f95ba861b761dd6b594ceb5b74c4e90f3 (diff)
downloadguix-f80215c7c4ae5ea0c316f4766e6c05ae4218ede3.tar.gz
gnu: python-google-api-client: Update to 1.12.8.
* gnu/packages/python-web.scm (python-google-api-client): Update to
1.12.8.
[arguments]: Remove custom phase to adjust setup.py.
[native-inputs]: Remove python-oauth2client, python-uritemplate. Move
python-httplib2, python-six ...
[propagated-inputs]: ... here. Add python-google-api-core-1,
python-google-auth-1, python-google-auth-httplib2, python-uritemplate-3.
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 569332d738..072d160c26 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4832,28 +4832,24 @@ Google search engine.  Its module is called @code{googlesearch}.")
 (define-public python-google-api-client
   (package
     (name "python-google-api-client")
-    (version "1.6.7")
+    (version "1.12.8")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "google-api-python-client" version))
        (sha256
         (base32
-         "1wpbbbxfpy9mwxdy3kn352cb590ladv574j1aa2l4grjdqw3ln05"))))
+         "1fq89wifa9ymby655is246w5d54ixybffj5vz7lwzhpf8926ifgk"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ; tests require internet access
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-setup-py
-           (lambda _
-             (substitute* "setup.py"
-               (("googleapiclient/discovery_cache")
-                "googleapiclient.discovery_cache"))
-             #t)))))
-    (native-inputs
-     (list python-httplib2 python-six python-oauth2client
-           python-uritemplate))
+     `(#:tests? #f))    ; tests require internet access
+    (propagated-inputs
+     (list python-google-api-core-1
+           python-google-auth-1
+           python-google-auth-httplib2
+           python-httplib2
+           python-six
+           python-uritemplate-3))
     (home-page "https://github.com/google/google-api-python-client")
     (synopsis "Core Python library for accessing Google APIs")
     (description "Python client library for Google's discovery based APIs")