summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-07-27 00:15:39 +0100
committerAndreas Enge <andreas@enge.fr>2023-08-07 20:36:25 +0200
commitf8ba0889f2a07eaac3551a5651400729b76eeec0 (patch)
treebed62a9bb59bfc5755d6a8026fdf6128a95d06c7
parent116bffeae45ae7bb742972ddea31eb8c5886ffdc (diff)
downloadguix-f8ba0889f2a07eaac3551a5651400729b76eeec0.tar.gz
gnu: python-fitsio: Enable tests.
* gnu/packages/astronomy.scm (python-fitsio): Enable tests.
[build-system]: Swap to pyproject-build-system.
[arguments]: Add new phase 'build-extensions.

Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/astronomy.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 078dc5d121..4ab3a186cb 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -545,7 +545,7 @@ mining in astronomy.")
             (delete-file-recursively "cfitsio3490")
             (substitute* "MANIFEST.in"
               (("recursive-include cfitsio3490.*$\n") ""))))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
       #:phases
@@ -562,7 +562,10 @@ mining in astronomy.")
                   (("self.system_fitsio_libdir = None") "pass")
                   (("self.use_system_fitsio") "True")
                   (("self.system_fitsio_includedir") includedir)
-                  (("self.system_fitsio_libdir") libdir))))))))
+                  (("self.system_fitsio_libdir") libdir)))))
+          (add-before 'check 'build-extensions
+            (lambda _
+              (invoke "python" "setup.py" "build_ext" "--inplace"))))))
     (native-inputs
      (list python-pytest))
     (inputs