summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-10 16:05:31 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-10 16:08:37 +0200
commitf8bb53caad90914aea3f3d2e82c64ce013561a15 (patch)
tree3d24f8554f7c852e2ceaa4b553594665004d2d48
parent22bff285b4b9bff836ce08de853ef1e5becca9b7 (diff)
downloadguix-f8bb53caad90914aea3f3d2e82c64ce013561a15.tar.gz
gnu: flann: Remove "octave" output.
Octave support currently fails to build and is not used by any other
package in Guix.

* gnu/packages/maths.scm (flann)[outputs]: Remove "octave" output.
[inputs]: Remove OCTAVE-CLI.
[arguments]: Remove 'set-octave-directory' phase.
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8fbce15418..d09ceea310 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3939,13 +3939,16 @@ in finite element programs.")
             "022w8hph7bli5zbpnk3z1qh1c2sl5hm8fw2ccim651ynn0hr7fyz"))
         (patches (search-patches "flann-cmake-3.11.patch"))))
     (build-system cmake-build-system)
-    (outputs '("out"
-               "octave"))                  ;46 MiB .mex file that pulls Octave
+    (outputs '("out"))
     (native-inputs
      `(("unzip" ,unzip)))
     (inputs
      `(("hdf5" ,hdf5)
-       ("octave" ,octave-cli)
+       ;; FIXME: 'mkoctfile' fails with a linker error:
+       ;;  ld: cannot find -loctinterp
+       ;;  ld: cannot find -loctave
+       ;; Disable it for now.
+       ;;("octave" ,octave-cli)
        ("python" ,python-2) ; print syntax
        ;; ("python2-numpy" ,python2-numpy) ; only required for the tests
        ("zlib" ,zlib)))
@@ -3958,14 +3961,6 @@ in finite element programs.")
        ;; Save 12 MiB by not installing .a files.  Passing
        ;; '-DBUILD_STATIC_LIBS=OFF' has no effect.
        #:phases (modify-phases %standard-phases
-                  (add-before 'configure 'set-octave-directory
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      ;; Install the .mex file in the "octave" output.
-                      (let ((out (assoc-ref outputs "octave")))
-                        (substitute* "src/matlab/CMakeLists.txt"
-                          (("share/flann/octave")
-                           (string-append out "/share/flann/octave")))
-                        #t)))
                   (add-after 'install 'remove-static-libraries
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))