summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-13 09:51:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-13 10:55:49 +0100
commitf90ed0284ad531633576392660bb6bf80d1c4388 (patch)
tree84f5288bdbe7f529221a180e082a91b69798675a
parentf6974e15cfce8128d9a3fb425671b1f6fc05e49b (diff)
downloadguix-f90ed0284ad531633576392660bb6bf80d1c4388.tar.gz
gnu: ledger: Update to 3.1.2 [security fixes].
* gnu/packages/finance.scm (ledger): Update to 3.1.2.
[arguments]: Remove #:modules; remove obsolete configure flags; remove make
flags; remove phase "boost-compat"; remove custom check phase; remove
"relocate-elisp" phase; disable broken test in "check-setup" phase.
[native-inputs]: Remove emacs-minimal.
[license]: Remove gpl2+.
* gnu/packages/patches/ledger-revert-boost-python-fix.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/finance.scm55
-rw-r--r--gnu/packages/patches/ledger-revert-boost-python-fix.patch39
3 files changed, 12 insertions, 83 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index af0337378c..1780ece26d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -932,7 +932,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/ldc-bootstrap-disable-tests.patch	\
   %D%/packages/patches/ldc-disable-phobos-tests.patch		\
   %D%/packages/patches/ledger-fix-uninitialized.patch		\
-  %D%/packages/patches/ledger-revert-boost-python-fix.patch	\
   %D%/packages/patches/liba52-enable-pic.patch			\
   %D%/packages/patches/liba52-link-with-libm.patch		\
   %D%/packages/patches/liba52-set-soname.patch			\
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 36cb508564..340c5b27dc 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -139,7 +139,7 @@ line client and a client based on Qt.")
 (define-public ledger
   (package
     (name "ledger")
-    (version "3.1.1")
+    (version "3.1.2")
     (source
      (origin
        (method git-fetch)
@@ -148,39 +148,17 @@ line client and a client based on Qt.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1j4p7djkmdmd858hylrsc3inamh9z0vkfl98s9wiqfmrzw51pmxp"))
-       (patches (search-patches "ledger-revert-boost-python-fix.patch"
-                                "ledger-fix-uninitialized.patch"))))
+        (base32 "0hwnipj2m9p95hhyv6kyq54m27g14r58gnsy2my883kxhpcyb2vc"))
+       (patches (search-patches "ledger-fix-uninitialized.patch"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:modules ((guix build cmake-build-system)
-                  ((guix build gnu-build-system) #:prefix gnu:)
-                  (guix build utils)
-                  (guix build emacs-utils))
-       #:imported-modules (,@%cmake-build-system-modules
-                           (guix build emacs-utils))
-       #:configure-flags
+     `(#:configure-flags
        `("-DBUILD_DOCS:BOOL=ON"
          "-DBUILD_WEB_DOCS:BOOL=ON"
-         "-DBUILD_EMACSLISP:BOOL=ON"
          "-DUSE_PYTHON:BOOL=ON"
-         "-DCMAKE_INSTALL_LIBDIR:PATH=lib"
-         ,(string-append "-DUTFCPP_INCLUDE_DIR:PATH="
-                         (assoc-ref %build-inputs "utfcpp")
-                         "/include"))
-       ;; Skip failing test BaselineTest_cmd-org during the check phase.
-       ;; This is a known upstream issue. See
-       ;; https://github.com/ledger/ledger/issues/550
-       #:make-flags (list "ARGS=-E BaselineTest_cmd-org")
+         "-DCMAKE_INSTALL_LIBDIR:PATH=lib")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'boost-compat
-           (lambda _
-             (substitute* "src/utils.h"
-               ;; This library moved in Boost 1.66.  Remove for Ledger
-               ;; versions > 3.1.1.
-               (("boost/uuid/sha1.hpp") "boost/uuid/detail/sha1.hpp"))
-             #t))
          (add-before 'configure 'install-examples
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((examples (string-append (assoc-ref outputs "out")
@@ -196,18 +174,11 @@ line client and a client based on Qt.")
              (setenv "TZDIR"
                      (string-append (assoc-ref inputs "tzdata")
                                     "/share/zoneinfo"))
-             #t))
-         (replace 'check (assoc-ref gnu:%standard-phases 'check))
-         (add-after 'install 'relocate-elisp
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((site-dir (string-append (assoc-ref outputs "out")
-                                             "/share/emacs/site-lisp"))
-                    (guix-dir (string-append site-dir "/guix.d"))
-                    (orig-dir (string-append site-dir "/ledger-mode"))
-                    (dest-dir (string-append guix-dir "/ledger-mode")))
-               (mkdir-p guix-dir)
-               (rename-file orig-dir dest-dir)
-               (emacs-generate-autoloads ,name dest-dir)))))))
+             ;; Skip failing test BaselineTest_cmd-org.
+             ;; This is a known upstream issue. See
+             ;; https://github.com/ledger/ledger/issues/550
+             (setenv "ARGS" "-E BaselineTest_cmd-org")
+             #t)))))
     (inputs
      `(("boost" ,boost)
        ("gmp" ,gmp)
@@ -217,8 +188,7 @@ line client and a client based on Qt.")
        ("tzdata" ,tzdata)
        ("utfcpp" ,utfcpp)))
     (native-inputs
-     `(("emacs" ,emacs-minimal)
-       ("groff" ,groff)
+     `(("groff" ,groff)
        ("texinfo" ,texinfo)))
     (home-page "https://ledger-cli.org/")
     (synopsis "Command-line double-entry accounting program")
@@ -244,8 +214,7 @@ in ability, and easy to use.")
                    license:asl2.0     ; src/strptime.cc
                    (license:non-copyleft
                     "file://src/wcwidth.cc"
-                    "See src/wcwidth.cc in the distribution.")
-                   license:gpl2+))))  ; lisp/*
+                    "See src/wcwidth.cc in the distribution.")))))
 
 (define-public geierlein
   (package
diff --git a/gnu/packages/patches/ledger-revert-boost-python-fix.patch b/gnu/packages/patches/ledger-revert-boost-python-fix.patch
deleted file mode 100644
index 99f48f6e46..0000000000
--- a/gnu/packages/patches/ledger-revert-boost-python-fix.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 01220484f428a447e9b00e071a0d85185f30e1de Mon Sep 17 00:00:00 2001
-From: Alexis Hildebrandt <afh@surryhill.net>
-Date: Wed, 22 Jun 2016 15:43:37 +0200
-Subject: [PATCH] Revert "[python] Add fix for Boost.Python compile errors"
-
-This reverts commit 11590e134eafa768ccc4a171cc7fb216e906095f.
----
- src/py_commodity.cc | 3 ---
- src/py_journal.cc   | 3 ---
- 2 files changed, 6 deletions(-)
-
-diff --git a/src/py_commodity.cc b/src/py_commodity.cc
-index 5aafa6c..c457e64 100644
---- a/src/py_commodity.cc
-+++ b/src/py_commodity.cc
-@@ -243,9 +243,6 @@ namespace {
- 
- void export_commodity()
- {
--#if BOOST_VERSION >= 106000
--  python::register_ptr_to_python< shared_ptr<commodity_pool_t> >();
--#endif
-   class_< commodity_pool_t, shared_ptr<commodity_pool_t>,
-           boost::noncopyable > ("CommodityPool", no_init)
-     .add_property("null_commodity",
-diff --git a/src/py_journal.cc b/src/py_journal.cc
-index c1c38a9..879f954 100644
---- a/src/py_journal.cc
-+++ b/src/py_journal.cc
-@@ -232,9 +232,6 @@ void export_journal()
-           boost::noncopyable >("PostHandler")
-     ;
- 
--#if BOOST_VERSION >= 106000
--  python::register_ptr_to_python< shared_ptr<collector_wrapper> >();
--#endif
-   class_< collector_wrapper, shared_ptr<collector_wrapper>,
-           boost::noncopyable >("PostCollectorWrapper", no_init)
-     .def("__len__", &collector_wrapper::length)