summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-21 00:43:00 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 19:43:08 +0200
commitf928abac369f699f425ddee925d0d0c2dc0a635d (patch)
tree95ca25e00ed82f881561e7b750b15ff7f3b341ac
parent7b83b3a77c5f1f74a460cdc712c186f4b2eb1d86 (diff)
downloadguix-f928abac369f699f425ddee925d0d0c2dc0a635d.tar.gz
gnu: python-deepmerge: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-deepmerge)[build-system]: Set to
PYPROJECT-BUILD-SYSTEM.
[arguments]: Remove obsolete phases.
[native-inputs]: Remove PYTHON-PYPA-BUILD and PYTHON-WHEEL.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 4 insertions, 21 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 368f6a8a78..18089d090e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30450,34 +30450,17 @@ object, which can be useful if you want to force your objects into a table.")
        (uri (pypi-uri "deepmerge" version))
        (sha256
         (base32 "06hagzg8ccmjzqvszdxb52jgx5il8a1jdz41n4dpkyyjsfg7fi2b"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'build 'set-version
             (lambda _
-              (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
-              ;; ZIP does not support timestamps before 1980.
-              (setenv "SOURCE_DATE_EPOCH" "315532800")))
-          (replace 'build
-            (lambda _
-              (invoke "python" "-m" "build" "--wheel"
-                      "--no-isolation" ".")))
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest"))))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl)))))))
+              (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
     (native-inputs
-     (list python-pypa-build
-           python-setuptools-scm
-           python-pytest
-           python-wheel))
+     (list python-setuptools-scm
+           python-pytest))
     (home-page "https://deepmerge.readthedocs.io/en/latest/")
     (synopsis "Merge nested data structures")
     (description