summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 13:55:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:31 +0200
commitf95f4d7a87ee45d268b24b1ca94eab03ecac3eb6 (patch)
tree524d581620ea0cecd2a099fa822343ff501eb461
parent99ee7d5340a691b0843d68c454c913a11f96f575 (diff)
downloadguix-f95f4d7a87ee45d268b24b1ca94eab03ecac3eb6.tar.gz
gnu: texlive-morefloats: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-morefloats!): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-IFTEX, TEXLIVE-KVOPTIONS.
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 19 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c26f972412..e550ef5fc4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11925,30 +11925,31 @@ include the addition of rules above or below a section title.")
     (license license:lppl1.2+)))
 
 (define-public texlive-morefloats
-  (let ((template (simple-texlive-package
-                   "texlive-morefloats"
-                   (list "/doc/latex/morefloats/"
-                         "/source/latex/morefloats/")
-                   (base32
-                    "0n0405fjxyjlbjspzfvhl0wjkwiqicj3hk8fa0g7agw72wlxscpl"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/morefloats")
-         ((#:build-targets _ '())
-          ''("morefloats.ins"))))
-      (home-page "https://www.ctan.org/pkg/morefloats")
-      (synopsis "Increase the number of simultaneous LaTeX floats")
-      (description "LaTeX can, by default, only cope with 18 outstanding floats;
+  (package
+    (name "texlive-morefloats")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/morefloats/"
+                   "source/latex/morefloats/"
+                   "tex/latex/morefloats/")
+             (base32
+              "0y8rd3ys71ys9cab172wwhrmbs9b52wqrj6d3p0iy3075z93h51c")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-iftex
+           texlive-kvoptions))
+    (home-page "https://ctan.org/pkg/morefloats")
+    (synopsis "Increase the number of simultaneous LaTeX floats")
+    (description "LaTeX can, by default, only cope with 18 outstanding floats;
 any more, and you get the error “too many unprocessed floats”.  This package
 releases the limit; TeX itself imposes limits (which are independent of the
 help offered by e-TeX).
 
 However, if your floats can’t be placed anywhere, extending the number of
 floats merely delays the arrival of the inevitable error message.")
-      (license license:lppl1.3c+))))
+    (license license:lppl1.3c+)))
 
 (define-public texlive-ifmtarg
   (package