summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:15:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:48 +0200
commitf9d207a2704f40a38c759905428f619382010deb (patch)
treefef4ca9bebc11b76433aa4f8a4847d9700138968
parentbaf3e73455e19b45c0c545cb9b98d78c0ba5194e (diff)
downloadguix-f9d207a2704f40a38c759905428f619382010deb.tar.gz
gnu: Add texlive-mluexercise.
* gnu/packages/tex.scm (texlive-mluexercise): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81ba7423d6..a424998955 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21789,6 +21789,32 @@ accented letters using ordinary Computer Modern (CM) fonts.  The system is
 distributed as a TeX change file.")
     (license license:knuth)))
 
+(define-public texlive-mluexercise
+  (package
+    (name "texlive-mluexercise")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mluexercise/"
+                   "source/latex/mluexercise/"
+                   "tex/latex/mluexercise/")
+             (base32
+              "1zvnz3rm9dq8h00hlbzll5cvw4zlcy8xr8l6cfjg0winfnyznky8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:build-targets #~(list "mluexercice.dtx")))
+    (home-page "https://ctan.org/pkg/mluexercise")
+    (synopsis
+     "Exercises and homework at the Martin Luther University Halle-Wittenberg")
+    (description
+     "This package provides a template class for solving weekly exercises at
+the Institute for Computer Science of Martin Luther University
+Halle-Wittenberg.  The class can be used by all students --- especially first
+semesters --- to typeset their exercises with low effort in beautiful LaTeX.
+A bunch of handy macros are included that are used throughout many lectures
+during the bachelor's degree program.")
+    (license license:expat)))
+
 (define-public texlive-mnsymbol
   (package
     (name "texlive-mnsymbol")