summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:58:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:06 +0200
commitf9dd940ea92d45b6574d6c78c01165e13932655a (patch)
tree6c2cb59ec5712333d8a7bf7287164bdd19acc8b4
parentb49e32e2d73298d75a7d5a36245438b866b268ae (diff)
downloadguix-f9dd940ea92d45b6574d6c78c01165e13932655a.tar.gz
gnu: Add texlive-pgfmath-xfp.
* gnu/packages/tex.scm (texlive-pgfmath-xfp): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a1ff6efee3..229cb0ca94 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -92101,6 +92101,30 @@ a noticeboard, with tear-off strips at the bottom where you can place contact
 details.")
     (license license:lppl)))
 
+(define-public texlive-pgfmath-xfp
+  (package
+    (name "texlive-pgfmath-xfp")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/pgfmath-xfp/"
+                   "source/latex/pgfmath-xfp/"
+                   "tex/latex/pgfmath-xfp/")
+             (base32
+              "1ss8wfqj5bmngzpcp0nfw6zm331bnjqa9x0ddfl1hf6i6j6c27b2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pgfmath-xfp")
+    (synopsis "Define pgfmath functions using @code{xfp}")
+    (description
+     "This package allows to define @code{pgfmath} functions that use the
+@code{xfp} FPU for their calculations.  The input arguments are parsed with
+@code{pgfmath}, and the results are forwarded to the FPU for the function
+evaluation.  The result of that calculation is then parsed by @code{pgfmath}
+again.  This way the functions should be usable in every @code{pgfmath}
+context, though there is some overhead to this approach.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar