summary refs log tree commit diff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2024-01-19 14:54:45 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-22 11:26:56 +0100
commitfa0b2cdab3a67299478972dba384ef0768f25897 (patch)
tree2c6aac35764572ff0cc5fb961ee3221bcf4321ac
parente5a00639aa6490f3f2047174be719d2defda9c4a (diff)
downloadguix-fa0b2cdab3a67299478972dba384ef0768f25897.tar.gz
gnu: make-crust-package: Update to 0.6.
* gnu/packages/firmware.scm (make-crust-package): Update to 0.6.  Do not
install host tool as it is not built by default.

Change-Id: Ia79ae8208589601d32235f6d8ace9dce3f8d74f9
-rw-r--r--gnu/packages/firmware.scm42
1 files changed, 8 insertions, 34 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index eb5251de5e..a2e3f785d5 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1202,7 +1202,7 @@ such as:
     (package
       (name (string-append "crust-"
                            (string-replace-substring platform "_" "-")))
-      (version "0.5")
+      (version "0.6")
       (source
        (origin
          (method git-fetch)
@@ -1213,43 +1213,19 @@ such as:
          (file-name (git-file-name "crust" version))
          (sha256
           (base32
-           "0xgbbhifg3miwd3yp6jq9kp7nqgz5gzy00w95vba45j8jk5vjvvz"))))
+           "1blq6bi2rmg4qqwwr07pamv28b50mwcsybhpn9bws8vbzxa43afd"))))
       (build-system gnu-build-system)
       (arguments
        (list
         #:tests? #f                       ;no test suite
         #:make-flags
-        (let ((triplet-without-vendor
-               (and (%current-target-system)
-                    ;; TODO: Is there a use case for allowing this?
-                    (not (target-avr?))
-                    (match (string-split (nix-system->gnu-triplet
-                                          (%current-target-system)) #\-)
-                      ((arch vendor os ..1)
-                       (string-join `(,arch ,@os) "-"))))))
-          #~(list "CROSS_COMPILE=or1k-elf-"
-                  "V=1"
-                  #$@(if triplet-without-vendor
-                         ;; We are cross-compiling the tools, intended to be
-                         ;; executable for the target system.
-                         (list (string-append "HOSTAR=" triplet-without-vendor
-                                              "-ar")
-                               (string-append "HOSTCC=" triplet-without-vendor
-                                              "-gcc"))
-                         ;; Not cross-compiling.
-                         (list "HOSTAR=ar"
-                               "HOSTCC=gcc"))
-                  "LEX=flex"))
+        #~(list "CROSS_COMPILE=or1k-elf-"
+                "V=1"
+                "HOSTAR=ar"
+                "HOSTCC=gcc"
+                "LEX=flex")
         #:phases
         #~(modify-phases %standard-phases
-            (add-after 'unpack 'do-not-build-tests
-              (lambda _
-                ;; Attempting to build the tools test binary on a non-aarch64
-                ;; architecture fails with: "No cache cleaning implementation
-                ;; available for this architecture".  Avoid building it (see:
-                ;; https://github.com/crust-firmware/crust/issues/182).
-                (substitute* "tools/Makefile"
-                  (("tools-y \\+= test") ""))))
             (delete 'configure)
             (add-before 'build 'defconfig
               (lambda* (#:key make-flags #:allow-other-keys)
@@ -1260,9 +1236,7 @@ such as:
                 (for-each (lambda (file)
                             (install-file file (string-append #$output
                                                               "/libexec")))
-                          (find-files "." "(scp\\.bin|\\.config)$"))
-                (install-file "build/tools/load"
-                              (string-append #$output "/bin")))))))
+                          (find-files "." "(scp\\.bin|\\.config)$")))))))
       ;; The firmware is cross-compiled using a "bare bones" compiler (no libc).
       ;; Use our own tool chain for that.
       (native-inputs