summary refs log tree commit diff
diff options
context:
space:
mode:
authorJOULAUD François <Francois.JOULAUD@radiofrance.com>2022-05-29 09:36:17 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-10 23:00:11 +0200
commitfa0ead00d970428c91be49d55102167c059a44a4 (patch)
tree33ce2324509707b8c7d0da4d150373c20f39b968
parentd859d8873ceb3c591210968cfd4c88e26fc89edc (diff)
downloadguix-fa0ead00d970428c91be49d55102167c059a44a4.tar.gz
gnu: Add go-sigs-k8s-io-yaml.
* gnu/packages/golang.scm (go-sigs-k8s-io-yaml): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 820e6b54ab..4c6e8e63f0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9775,3 +9775,33 @@ Features:
      "@code{go-github-com-go-chi-chi-v5} is an HTTP router that lets the user
 decompose request handling into many smaller layers.")
     (license license:expat)))
+
+(define-public go-sigs-k8s-io-yaml
+  (package
+    (name "go-sigs-k8s-io-yaml")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/kubernetes-sigs/yaml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qxs0ppqwqrfqs4aywyn1h28xh1qlj5ds4drmygaz1plrxj02dqn"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "sigs.k8s.io/yaml"))
+    (propagated-inputs (list go-gopkg-in-yaml-v2 go-github-com-davecgh-go-spew))
+    (home-page "https://sigs.k8s.io/yaml")
+    (synopsis "YAML marshaling and unmarshaling support for Go")
+    (description
+     "This package provides a Go library that first converts YAML to JSON
+using @code{go-yaml} and then uses @code{json.Marshal} and
+@code{json.Unmarshal} to convert to or from the struct. This means that
+it effectively reuses the JSON struct tags as well as the custom JSON
+methods @code{MarshalJSON} and @code{UnmarshalJSON} unlike
+@code{go-yaml}.
+
+kubernetes-sigs/yaml is a permanent fork of
+@url{https://github.com/ghodss/yaml,ghodss/yaml}.")
+    (license (list license:expat license:bsd-3))))