summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-08-09 19:19:03 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-08-12 02:50:21 +0530
commitfab8a9f9c33e889e70a3fb2358d986c72e17efc3 (patch)
treef70ec4be0527ee2fa15d1f6e41be3d8f63192d95
parent7e72f5471bb1890f2f0ecc14bcc2be6047131f27 (diff)
downloadguix-fab8a9f9c33e889e70a3fb2358d986c72e17efc3.tar.gz
gnu: ccid: Move pcsc-lite from inputs to native-inputs.
pcsc-lite only provides the headers to build ccid. So, it is sufficient that
it be a native-input.

* gnu/packages/security-token.scm (ccid)[inputs]: Move pcsc-lite to ...
[native-inputs]: ... here.
-rw-r--r--gnu/packages/security-token.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 7fdcaaf1ea..68cda50170 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -75,11 +76,11 @@
                (("/bin/echo") (which "echo")))
              #t)))))
     (native-inputs
-     `(("perl" ,perl)
+     `(("pcsc-lite" ,pcsc-lite) ; only required for headers
+       ("perl" ,perl)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("libusb" ,libusb)
-       ("pcsc-lite" ,pcsc-lite)))
+     `(("libusb" ,libusb)))
     (home-page "https://ccid.apdu.fr/")
     (synopsis "PC/SC driver for USB smart card devices")
     (description