summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-23 02:00:00 +0200
commitfad1165fdbcd5be96fa02803e2606648d707f94f (patch)
tree2c6e9f3061f4d68aedecf9bf3e757a4e05430538
parent157db85f6d2a37c51e93249eed5f1c0cb06f746d (diff)
downloadguix-fad1165fdbcd5be96fa02803e2606648d707f94f.tar.gz
gnu: hamlib: Rebuild broken configure script.
* gnu/packages/radio.scm (hamlib)[native-inputs]: Add autoconf, automake, and libtool.
[arguments]: Add a new 'force-bootstrap phase.
-rw-r--r--gnu/packages/radio.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index e1774169ec..4e50ef8ff4 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1226,7 +1226,10 @@ you must extend 'udev-service-type' with this package.  E.g.:
         (base32 "11r4i8gmxnb6ixpk4ns38c9xwj3qibp2v3pkhy2z0lhz0xxi1w4b"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list doxygen
+     (list autoconf
+           automake
+           doxygen
+           libtool
            lua
            pkg-config
            python-wrapper
@@ -1235,11 +1238,19 @@ you must extend 'udev-service-type' with this package.  E.g.:
     (inputs
      (list gd libusb libxml2 readline))
     (arguments
-     `(#:configure-flags '("--disable-static"
-                           "--with-lua-binding"
-                           "--with-python-binding"
-                           "--with-tcl-binding"
-                           "--with-xml-support")))
+     `(#:configure-flags
+       '("--disable-static"
+         "--with-lua-binding"
+         "--with-python-binding"
+         "--with-tcl-binding"
+         "--with-xml-support")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'bootstrap 'force-bootstrap
+           ;; The included configure script is misbuilt.  It will never find
+           ;; pkg-config, and hence any libraries that rely on it.  Rebuild it.
+           (lambda _
+             (delete-file "configure"))))))
     (synopsis "Tools and API to control radios")
     (description
      "The Ham Radio Control Library (Hamlib) is a project to provide programs