summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-28 14:17:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 14:17:55 +0100
commitfb2477f6d2fc9e41b226dae1f88723fd92b03c1c (patch)
treedb4b98b4f8ad47db613f7cb5ac4b2cdf17d85dd7
parent836de07a47aa4a982fe99b774da2db53e235f2ca (diff)
downloadguix-fb2477f6d2fc9e41b226dae1f88723fd92b03c1c.tar.gz
gnu: python-psutil: Update to 5.4.3.
* gnu/packages/python.scm (python-psutil): Update to 5.4.3.
[properties]: Declare python2 variant.
(python2-psutil): Propagate PYTHON2-ENUM34.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fc906e6858..fa8f4902d2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -448,14 +448,14 @@ instead of @command{python3}.")))
 (define-public python-psutil
   (package
     (name "python-psutil")
-    (version "4.3.0")
+    (version "5.4.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "psutil" version))
        (sha256
         (base32
-         "1w4r09fvn6kd80m5mx4ws1wz100brkaq6hzzpwrns8cgjzjpl6c6"))))
+         "063v69x7spyclyaxrd3gmzj3p16q5ayg97xqhwb1kyn22a9pwip2"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: some tests does not return and times out.
@@ -470,10 +470,16 @@ limiting process resources and management of running processes.  It implements
 many functionalities offered by command line tools such as: ps, top, lsof,
 netstat, ifconfig, who, df, kill, free, nice, ionice, iostat, iotop, uptime,
 pidof, tty, taskset, pmap.")
+    (properties `((python2-variant . ,(delay python2-psutil))))
     (license license:bsd-3)))
 
 (define-public python2-psutil
-  (package-with-python2 python-psutil))
+  (let ((base (package-with-python2 (strip-python2-variant python-psutil))))
+    (package
+      (inherit base)
+      (propagated-inputs
+       `(("python2-enum34" ,python2-enum34)         ;optional
+         ,@(package-propagated-inputs base))))))
 
 (define-public python-shapely
   (package