summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-10-28 15:56:22 +0100
committerAndreas Enge <andreas@enge.fr>2015-10-28 15:57:20 +0100
commitfb8d1be8e125722226fe3d2ae7dedb6ba7015290 (patch)
treea3649b02b2db34426e52983c19bf9c0bc1ca3be6
parent855038b294853e4e81a6a2430c33f42495d98b6b (diff)
downloadguix-fb8d1be8e125722226fe3d2ae7dedb6ba7015290.tar.gz
gnu: pari-gp: Add X11 input.
* gnu/packages/algebra.scm (pari-gp)[inputs]: Add libx11, which enables
  plotting functions.
-rw-r--r--gnu/packages/algebra.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2f52f5545c..daa5ddd072 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -26,6 +26,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages xorg)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -125,6 +126,7 @@ solve the shortest vector problem.")
                 "0k1qqagfl6zn7gvwmsqffj6g9yrzqvszwh2mblhmxpjlw1pigfh8"))))
    (build-system gnu-build-system)
    (inputs `(("gmp" ,gmp)
+             ("libx11" ,libx11)
              ("perl" ,perl)
              ("readline" ,readline)))
    (arguments