summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 23:51:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:26 +0200
commitfbae0395fd6d07059637dc38804331bb88098c1e (patch)
tree9b332cc3015e9c823f22e80ab4907bf5df450d9d
parent54af21813440010ef441c5dbcbc45e887871551e (diff)
downloadguix-fbae0395fd6d07059637dc38804331bb88098c1e.tar.gz
gnu: Add texlive-arara.
* gnu/packages/tex.scm (texlive-arara): New variable.
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b66f3c386e..de7bca00ad 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -81,6 +81,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages java)
   #:use-module (gnu packages libreoffice)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages multiprecision)
@@ -1156,6 +1157,40 @@ ligatures, but also offers additional control over them.")
 a given (Unicode) glyph.  It relies on Fontconfig.")
     (license license:bsd-3)))
 
+(define-public texlive-arara
+  (package
+    (name "texlive-arara")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/arara.1"
+                   "doc/man/man1/arara.man1.pdf"
+                   "doc/support/arara/" "scripts/arara/"
+                   "source/support/arara/")
+             (base32
+              "0sshjaxz1ar24mr7dny0lp9l0bggyfsb0868s4b1k00w6jyzh1i8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     (list
+      #:link-scripts #~(list "arara.sh")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'locate-java
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* "scripts/arara/arara.sh"
+                (("java") (search-input-file inputs "/bin/java"))))))))
+    (inputs (list icedtea))
+    (home-page "https://ctan.org/pkg/arara")
+    (synopsis "Automation of LaTeX compilation")
+    (description
+     "Arara is comparable with other well-known compilation tools like
+@command{latexmk} and @command{rubber}.  The key difference is that Arara
+determines its actions from metadata in the source code, rather than relying
+on indirect resources, such as log file analysis.  Arara requires a Java
+virtual machine.")
+    (license license:bsd-3)))
+
 (define-public texlive-dosepsbin
   (package
     (name "texlive-dosepsbin")