summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-27 15:30:20 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-27 15:32:39 +0200
commitfc2f38023bf95604b2eac73bee336b4c3909b480 (patch)
tree48b4bc50f158fda1ef3fa95034a834e25f31720e
parent0778385802a7f2eb8c661301e37417e7add81261 (diff)
downloadguix-fc2f38023bf95604b2eac73bee336b4c3909b480.tar.gz
build: Use `pre-inst-env' to compile the source.
* Makefile.am (.scm.go): Use `pre-inst-env' instead of re-defining the
  environment variables, except for `DISTRO_INSTALLED_PATCH_DIRECTORY'
  and `DISTRO_INSTALLED_BOOTSTRAP_DIRECTORY'.
-rw-r--r--Makefile.am18
1 files changed, 6 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 35c477ea6a..1d3eafb6ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -130,18 +130,12 @@ CLEANFILES = $(GOBJECTS) *.log
 
 .scm.go:
 	$(MKDIR_P) `dirname "$@"`
-	NIX_INSTANTIATE="$(NIX_INSTANTIATE)"					\
-	NIXPKGS="$(NIXPKGS)"							\
-	LIBGCRYPT="$(LIBGCRYPT)"						\
-	DISTRO_PATCH_DIRECTORY="$(top_srcdir)/distro/patches"			\
-	DISTRO_INSTALLED_PATCH_DIRECTORY="$(patchdir)"				\
-	DISTRO_BOOTSTRAP_DIRECTORY="$(top_srcdir)/distro/packages/bootstrap"	\
-	DISTRO_INSTALLED_BOOTSTRAP_DIRECTORY="$(bootstrapdir)"			\
-	GUILE_AUTO_COMPILE=0							\
-	GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH"	\
-	$(GUILD) compile -L "$(top_srcdir)"					\
-	  -Wformat -Wunbound-variable -Warity-mismatch				\
-	  --target="$(host)"							\
+	DISTRO_INSTALLED_PATCH_DIRECTORY="$(patchdir)"		\
+	DISTRO_INSTALLED_BOOTSTRAP_DIRECTORY="$(bootstrapdir)"	\
+	$(top_builddir)/pre-inst-env				\
+	$(GUILD) compile -L "$(top_srcdir)"			\
+	  -Wformat -Wunbound-variable -Warity-mismatch		\
+	  --target="$(host)"					\
 	  -o "$@" "$<"
 
 SUFFIXES = .go