summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-27 11:28:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-01 12:41:33 +0100
commitfca17c0b2872017aa6bd979a7773b4a269489321 (patch)
tree2e57d9376be8dbd5e0ff0ad20fbc35f6d7adf7f2
parente59eb3fe63a5b0b73592c7c07f85dae90d785de0 (diff)
downloadguix-fca17c0b2872017aa6bd979a7773b4a269489321.tar.gz
gnu: Add r-drat.
* gnu/packages/cran.scm (r-drat): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a1da9d229e..91a4797c43 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6380,6 +6380,30 @@ these progress updates.")
 variable models.")
     (license license:gpl3)))
 
+(define-public r-drat
+  (package
+    (name "r-drat")
+    (version "0.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "drat" version))
+       (sha256
+        (base32 "191yxlj9jccakmz27g7n9izfcy19kj3fgnw4w6zl9iq66787qpm6"))))
+    (properties `((upstream-name . "drat")))
+    (build-system r-build-system)
+    (native-inputs (list r-simplermarkdown))
+    (home-page "https://github.com/eddelbuettel/drat")
+    (synopsis "Drat R archive template")
+    (description
+     "This package helps you with creation and use of R repositories via
+helper functions to insert packages into a repository, and to add repository
+information to the current R session.  Two primary types of repositories are
+supported: gh-pages at GitHub, as well as local repositories on either the
+same machine or a local network.  Drat is a recursive acronym: Drat R Archive
+Template.")
+    (license license:gpl2+)))
+
 (define-public r-drr
   (package
     (name "r-drr")