summary refs log tree commit diff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-07-15 17:43:13 -0400
committerArun Isaac <arunisaac@systemreboot.net>2021-08-01 18:14:55 +0530
commitfcba63f8b7806493fc5060b267af93cdb7d21aa6 (patch)
treea0dc18fa653883b12696f35d6e7273c415b005f1
parent5ab679f4dacbc8c6da3a551e284cb41d6a0f6792 (diff)
downloadguix-fcba63f8b7806493fc5060b267af93cdb7d21aa6.tar.gz
gnu: Add emacs-autocrypt.
* gnu/packages/emacs-xyz.scm (emacs-autocrypt): New variable.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d2fafd09a1..a506501679 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12297,6 +12297,34 @@ a visual interface, reduce overhead of completion by using statistic method,
 extensibility.")
     (license license:gpl3+)))
 
+(define-public emacs-autocrypt
+  (let ((commit "5b55f8d37545e9c441788627c17e350d7edf4055")
+        (revision "0"))
+    (package
+      (name "emacs-autocrypt")
+      (version (git-version "0.4.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.sr.ht/~zge/autocrypt")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0b06xnjkgwjpxl96mdi674pmvdaiwncifi1a30wxhl1dwr7kr084"))))
+      (build-system emacs-build-system)
+      (home-page "https://git.sr.ht/~zge/autocrypt")
+      (synopsis "Autocrypt implementation for Emacs")
+      (description "@code{emacs-autocrypt} is an implementation of
+Autocrypt (@url{https://autocrypt.org/}) for various Emacs MUAs.  Autocrypt is
+a cryptographic protocol for email clients aiming to simplify key exchange and
+encryption.
+
+Run @code{M-x autocrypt-create-account} to initialize an autocrypt key, and
+add @code{autocrypt-mode} to your MUA's hooks (@code{gnus-mode-hook},
+@code{message-mode-hook}, ...) to activate its usage.")
+      (license license:cc0))))
+
 (define-public emacs-nginx-mode
   (package
     (name "emacs-nginx-mode")