summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-16 16:35:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-16 16:35:50 +0300
commitfcc93efc565b85280c9ea6a531f9cd38eb5ddea7 (patch)
treedabf294a25e0b4555ddbb7ac9e1557b5b545ad60
parentddcc5d43757f3b1f7460994e5a22abeb2f0ab648 (diff)
downloadguix-fcc93efc565b85280c9ea6a531f9cd38eb5ddea7.tar.gz
gnu: Add julia-iocapture.
* gnu/packages/julia-xyz.scm (julia-iocapture): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index fe16d85ea7..68ec6d8c64 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -790,6 +790,27 @@ implementing both a client and a server.")
 interfaces with @file{.ini} files.")
     (license license:expat)))
 
+(define-public julia-iocapture
+  (package
+    (name "julia-iocapture")
+    (version "0.2.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaDocs/IOCapture.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0ajlfh8f1g23bx5f8h70nrgr0zfwxaqnpxlka8l4qhjmnfqxl43a"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaDocs/IOCapture.jl")
+    (synopsis "Capture standard output and error streams")
+    (description "This package provides the @code{IOCapture.capture(f)}
+function, which captures the standard output and standard error, and returns it
+as a string together with the return value.")
+    (license license:expat)))
+
 (define-public julia-irtools
   (package
     (name "julia-irtools")