summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 00:23:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:00 +0200
commitfdff8fcc0f4951d83f0c2cd7501b76fbf1ed2195 (patch)
treed53d2b3b346f03e2ddc29e1d09d1d914487b141e
parent927fd738e626bd25dc9e8561223019575b19bfaa (diff)
downloadguix-fdff8fcc0f4951d83f0c2cd7501b76fbf1ed2195.tar.gz
gnu: Add texlive-hopatch.
* gnu/packages/tex.scm (texlive-hopatch): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 214c4a6e45..dfd4f0d68f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -782,6 +782,29 @@ out to date by @code{unicode-letters.tex}.")
 
 (define-deprecated-package texlive-generic-unicode-data texlive-unicode-data)
 
+(define-public texlive-hopatch
+  (package
+    (name "texlive-hopatch")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/hopatch/" "source/latex/hopatch/"
+                   "tex/latex/hopatch/")
+             (base32
+              "1yc9pzh8h4caaxii197jzd8wmvj754ymdq5x2hvmn171mxqp4d3v")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-ltxcmds))
+    (home-page "https://ctan.org/pkg/hopatch")
+    (synopsis "Load patches for packages")
+    (description
+     "Hopatch provides a command with which the user may register of patch code
+for a particular package.  Hopatch will apply the patch immediately, if the
+relevant package has already been loaded; otherwise it will store the patch
+until the package appears.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-hyphen-base
   (package
     (inherit (simple-texlive-package