summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-04-19 01:43:04 -0400
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-04-19 11:46:55 +0200
commitfe5c36728f9e1287f621070383c54387f487a4a1 (patch)
tree0fe44592f04de7bf81ff5d57521c7d4eca312a93
parent0e5c5ec52c42788e02a58154cb7ea3b5c7bad447 (diff)
downloadguix-fe5c36728f9e1287f621070383c54387f487a4a1.tar.gz
gnu: Add gnome-2048.
* gnu/packages/games.scm (gnome-2048): New variable.

Co-authored-by: Carla Cao <ccao001@fiu.edu>
Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
-rw-r--r--gnu/packages/games.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 91ac839aee..5b316f1997 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1623,6 +1623,50 @@ destroying an ancient book using a special wand.")
     ;; license.  The whole package is released under GPLv3+.
     (license license:gpl3+)))
 
+(define-public gnome-2048
+  (package
+    (name "gnome-2048")
+    (version "3.38.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/gnome-2048/"
+                                  (version-major+minor version)  "/"
+                                  "gnome-2048-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0s5fg4z5in1h39fcr69j1qc5ynmg7a8mfprk3mc3c0csq3snfwz2"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t)))))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("clutter" ,clutter)
+       ("clutter-gtk" ,clutter-gtk)
+       ("libgee" ,libgee)
+       ("libgnome-games-support" ,libgnome-games-support)))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin") ; for desktop-file-validate and appstream-util
+       ("itstool" ,itstool)
+       ("libxml2" ,libxml2)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)))
+    (home-page "https://wiki.gnome.org/Apps/2048")
+    (synopsis "Move the tiles until you obtain the 2048 tile")
+    (description "GNOME 2048 provides a 2D grid for playing 2048, a
+single-player sliding tile puzzle game.  The objective of the game is to merge
+together adjacent tiles of the same number until the sum of 2048 is achieved
+in one tile.")
+    (license license:gpl3+)))
+
 (define-public gnome-chess
   (package
     (name "gnome-chess")