summary refs log tree commit diff
diff options
context:
space:
mode:
authorJaeme Sifat <jaeme@runbox.com>2023-10-29 00:26:58 -0400
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:26 +0200
commitffadfb0e538686aa91e0472a7e19e3c6bbaf6ebb (patch)
tree6a189f2d3e2c9965efff99d201e6dfd3694cb3b0
parent73a7985e50026832ba5dbd1a329a86de4d6e370f (diff)
downloadguix-ffadfb0e538686aa91e0472a7e19e3c6bbaf6ebb.tar.gz
gnu: Add rust-partition-identity-0.3.
* gnu/packages/crates-io.scm (rust-partition-identity-0.3): New variable.

Signed-off-by: Jaeme Sifat <jaeme@runbox.com>
Change-Id: I8f61580cb1e31965564c8c7699e6218b78b82fd4
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b1091ef9c5..4117d7f479 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -51765,6 +51765,28 @@ and would-block I/O operations.")
         ("rust-tokio-core" ,rust-tokio-core-0.1))))
     (license license:bsd-3)))
 
+(define-public rust-partition-identity-0.3
+  (package
+    (name "rust-partition-identity")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "partition-identity" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "08cymccnyf2b0pwc7x4wj889k1knqmrb8500idsjslybpvwjbacz"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-thiserror" ,rust-thiserror-1))))
+    (home-page "https://github.com/pop-os/partition-identity")
+    (synopsis
+     "Find the ID of a device by its path, or find a device path by its ID")
+    (description
+     "This package provides the ability to find ID of a device by its path, or
+find a device path by its ID.")
+    (license license:expat)))
+
 (define-public rust-pasetors-0.6
   (package
     (name "rust-pasetors")