summary refs log tree commit diff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2023-02-27 21:06:27 -0500
committerLeo Famulari <leo@famulari.name>2023-03-02 13:49:46 -0500
commitffb756e8c008e64d05b510e365d5e6b907c65747 (patch)
tree88a2e660b4e2683147fa49f729ab91557440b672
parente9c1ea84fcf4a7f3da9aea9fbfe6136c75643c07 (diff)
downloadguix-ffb756e8c008e64d05b510e365d5e6b907c65747.tar.gz
gnu: python-acme, certbot: Update to 2.3.0.
* gnu/packages/tls.scm (python-acme): Update to 2.3.0.
(certbot)[source]: Update hash.
[propagated-inputs]: Remove python-zope-interface and
python-zope-component.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/tls.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 59e0e28feb..81d90c86ae 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -764,13 +764,13 @@ netcat implementation that supports TLS.")
   (package
     (name "python-acme")
     ;; Remember to update the hash of certbot when updating python-acme.
-    (version "1.28.0")
+    (version "2.3.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "acme" version))
               (sha256
                (base32
-                "12fmw4g63pzbrmmrkk6hgg0k5px6jyx3scv9fmn60h21387jv0hz"))))
+                "1z6293g4pyxvx5w7v07j8wnaxyr7srsqfqvgly888b8k52fq9ipa"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -822,7 +822,7 @@ netcat implementation that supports TLS.")
               (uri (pypi-uri "certbot" version))
               (sha256
                (base32
-                "0p4cpakx1kc8lczlgxqryr2asnyrvw6p5wmkamkjqdsf3z7xhm2b"))))
+                "12nd9nmdj3bf1xlvhj1ln473xbyv4qzxf6qhz0djbca7jl59zlwk"))))
     (build-system python-build-system)
     (arguments
      `(,@(substitute-keyword-arguments (package-arguments python-acme)
@@ -850,13 +850,11 @@ netcat implementation that supports TLS.")
     (propagated-inputs
      (list python-acme
            python-cryptography
-           python-zope-interface
            python-pyrfc3339
            python-pyopenssl
            python-configobj
            python-configargparse
            python-distro
-           python-zope-component
            python-parsedatetime
            python-psutil
            python-requests