summary refs log tree commit diff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2022-08-13 16:40:58 -0700
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2022-09-21 22:05:07 +0200
commitfff6407df39e624dac6538eea27d182612a4d765 (patch)
tree855ae818d55cd108fff7d85d714ec07b9cbd8888
parent6885f22375b093c08d69bbed6aa42d2e8c11a168 (diff)
downloadguix-fff6407df39e624dac6538eea27d182612a4d765.tar.gz
gnu: Add python-suntime.
* gnu/packages/astronomy.scm (python-suntime): New variable.

Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
-rw-r--r--gnu/packages/astronomy.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 29f1e6fc36..87c290f58f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1823,6 +1823,27 @@ N-Chilada and RAMSES AMR outputs.")
      (modify-inputs (package-inputs libsep)
        (prepend python-numpy)))))
 
+(define-public python-suntime
+  (package
+    (name "python-suntime")
+    (version "1.2.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "suntime" version))
+              (sha256
+               (base32
+                "0ja64w293wjx76q3z18ikx4rdihwkbj6pnjpbs82ycyyzhfnbpz4"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-dateutil))
+    (home-page "https://github.com/SatAgro/suntime")
+    (synopsis "Sunset and sunrise time calculation python library")
+    (description
+     "Python library doing sunrise and sunset time calculation.
+
+Takes a WGS84 (GPS) latitude/longitude as input as well as an UTC or local
+datetime object.")
+    (license license:lgpl3+)))
+
 (define-public python-asdf
   (package
     (name "python-asdf")