summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:04:59 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:20 +0200
commitfffb1e725b31d59d6825e8902a72f33f27de44c2 (patch)
tree59ee057aed46b6121463bbbeeb109ab4fedfc62e
parent13a8b866b193e65113620ee43eecbb8d94c1bbfb (diff)
downloadguix-fffb1e725b31d59d6825e8902a72f33f27de44c2.tar.gz
gnu: Add julia-example.
* gnu/packages/julia-xyz.scm (julia-example): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ab238161e9..f21ea0afb0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -240,6 +240,26 @@ including, @code{CircularBuffer}, @code{Queue}, @code{Stack},
 @code{Accumulators}, @code{LinkedLists}, @code{SortedDicts} and many others.")
     (license license:expat)))
 
+(define-public julia-example
+  (let ((commit "f968c69dea24f851d0c7e686db23fa55826b5388"))
+    (package
+      (name "julia-example")
+      (version "0.5.4")                   ;tag not created upstream
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/JuliaLang/Example.jl")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1v3z0d6gh6wfbypffy9m9rhh36px6fm5wjzq0y6rbmc95r0qpqlx"))))
+      (build-system julia-build-system)
+      (home-page "https://github.com/JuliaLang/Example.jl")
+      (synopsis "Module providing examples")
+      (description "This package provides various examples.")
+      (license license:expat))))
+
 (define-public julia-fixedpointnumbers
   (package
     (name "julia-fixedpointnumbers")