summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-30 17:46:50 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-30 20:02:41 +0100
commit020184fd39c6244e0336db3c608d3946b8d20490 (patch)
tree46114f3bfdb275cc17cff76492876d1f385a4cc9 /Makefile.am
parent1aa7ee52c6c520c2dbbdb06f1381466e9fd96294 (diff)
downloadguix-020184fd39c6244e0336db3c608d3946b8d20490.tar.gz
maint: Adjust sed script from 'release' target. v1.4.0rc1
This is a followup to fdafd404325413da4d5fdd717c84e57a51c60fe2.  This
effect would to set 'GUIX_DISPLAYED_VERSION' to the empty string.

* Makefile.am (release): Remove '/v' from sed script for
GUIX_DISPLAYED_VERSION.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8aa3fe9cec..f410af4094 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1002,7 +1002,7 @@ release: dist-with-updated-version all
 	      -v1 --no-grafts --fallback
 # Generate the ISO installation images.
 	for system in $(GUIX_SYSTEM_SUPPORTED_SYSTEMS) ; do				\
-	  GUIX_DISPLAYED_VERSION="`git describe --match=v* | sed -'es/^v//v'`" ;	\
+	  GUIX_DISPLAYED_VERSION="`git describe --match=v* | sed -'es/^v//'`" ;		\
 	  image=`$(top_builddir)/pre-inst-env						\
 	    guix system image -t iso9660						\
 	    --label="GUIX_$${system}_$(VERSION)"					\
@@ -1018,7 +1018,7 @@ release: dist-with-updated-version all
 	done
 # Generate the VM images.
 	for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do					\
-	  GUIX_DISPLAYED_VERSION="`git describe --match=v* | sed -'es/^v//v'`" ;	\
+	  GUIX_DISPLAYED_VERSION="`git describe --match=v* | sed -'es/^v//'`" ;		\
 	  image=`$(top_builddir)/pre-inst-env						\
 	    guix system image -t qcow2 $(GUIX_SYSTEM_VM_IMAGE_FLAGS)			\
 	    --save-provenance								\