summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-06-25 15:09:26 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-25 15:12:06 +0200
commit0a02abde88ce16315277239c081c6222a4db88d2 (patch)
tree66c01f11e638da9ddb89008a86d51290fad7af3d /Makefile.am
parentdfac3e643a924ccefc997b4433a0b5c35928d657 (diff)
downloadguix-0a02abde88ce16315277239c081c6222a4db88d2.tar.gz
build: Build guix.scm and gnu.scm.
Fixes a regression introduced in
ef82ba9dd94369926eb13325d5e7da4306d23dd7 that was causing these two
files to not be built.  In turn, 'tests/inferior.scm' would determine
the wrong %TOP-BUILDDIR value, causing the "&inferior-exception" test to
fail because for lack of an inferior stack trace.

* Makefile.am (MODULES_CORE): Add guix.scm.
(MODULES_SYSTEM): Add gnu.scm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bb5de007e..dd34447020 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -690,9 +690,9 @@ endef
 # in <https://issues.guix.gnu.org/48963>.  Each 'eval' call below creates a
 # 'make-*-go' phony target that builds the corresponding subset.
 
-MODULES_CORE     = $(filter-out guix/scripts/%,$(filter guix/%,$(MODULES)))
+MODULES_CORE     = guix.scm $(filter-out guix/scripts/%,$(filter guix/%,$(MODULES)))
 MODULES_PACKAGES = $(filter gnu/packages/%,$(MODULES))
-MODULES_SYSTEM   = $(filter-out gnu/packages/%,$(filter gnu/%,$(MODULES)))
+MODULES_SYSTEM   = gnu.scm $(filter-out gnu/packages/%,$(filter gnu/%,$(MODULES)))
 MODULES_CLI      = $(filter guix/scripts/%,$(MODULES))
 
 $(eval $(call guile-compilation-rule,make-core-go,	\