summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-21 14:08:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-23 23:37:10 -0400
commit7aeef7ee3dbf8d8f4e4c741de021ad4eba4149aa (patch)
treed1e67a25f8ab03fd7d128350180ee6695ed856ce /Makefile.am
parent52d71fe8dd924a28ff39a988cc65d660dab989f8 (diff)
downloadguix-7aeef7ee3dbf8d8f4e4c741de021ad4eba4149aa.tar.gz
build: Use guix system image instead of disk-image, vm-image.
These older system actions are deprecated and cause warnings to be emitted.

* Makefile.am (release) <guix system disk-image>
<guix system vm-image>: Replace by...
<guix system image>: ... this.  Specify the type of the VM image as qcow2.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5600bd5503..062a7ba154 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -880,7 +880,7 @@ release: dist-with-updated-version
 	      -v1 --no-grafts --fallback
 	for system in $(GUIX_SYSTEM_SUPPORTED_SYSTEMS) ; do				\
 	  image=`$(top_builddir)/pre-inst-env						\
-	    guix system disk-image -t iso9660                                           \
+	    guix system image -t iso9660                                           	\
 	    --label="GUIX_$${system}_$(VERSION)"					\
             --system=$$system --fallback						\
 	    gnu/system/install.scm` ;							\
@@ -894,7 +894,7 @@ release: dist-with-updated-version
 	done
 	for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do					\
 	  image=`$(top_builddir)/pre-inst-env						\
-	    guix system vm-image $(GUIX_SYSTEM_VM_IMAGE_FLAGS)				\
+	    guix system image -t qcow2 $(GUIX_SYSTEM_VM_IMAGE_FLAGS)			\
 	    --save-provenance								\
 	    --system=$$system --fallback						\
 	    gnu/system/examples/vm-image.tmpl` ;					\