summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-01 19:21:06 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-02 16:13:49 +0200
commita5071b990dd0a98069d1a92cde83dcc1eaf4f89a (patch)
tree53f6749cd7b97ae607a3f6988297f837c0a0344e /Makefile.am
parent472894aae8b59fa45dccb2b9cef9ff6ed27b152d (diff)
downloadguix-a5071b990dd0a98069d1a92cde83dcc1eaf4f89a.tar.gz
distro: diffutils: Allow builds with glibc 2.16+.
* distro/patches/diffutils-gets-undeclared.patch: New file.
* Makefile.am (dist_patch_DATA): Add it.

* distro/base.scm (diffutils): Apply. `diffutils-gets-undeclared.patch'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ba72cf94c..381a615f2e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,15 +38,16 @@ GOBJECTS = $(MODULES:%.scm=%.go)
 nobase_dist_guilemodule_DATA = $(MODULES)
 
 patchdir = $(pkgdatadir)/patches
-dist_patch_DATA =				\
-  distro/patches/binutils-ld-new-dtags.patch	\
-  distro/patches/guile-1.8-cpp-4.5.patch	\
-  distro/patches/m4-gets-undeclared.patch	\
-  distro/patches/m4-readlink-EINVAL.patch	\
-  distro/patches/m4-s_isdir.patch		\
-  distro/patches/make-impure-dirs.patch		\
-  distro/patches/findutils-absolute-paths.patch	\
-  distro/patches/readline-link-ncurses.patch	\
+dist_patch_DATA =					\
+  distro/patches/binutils-ld-new-dtags.patch		\
+  distro/patches/diffutils-gets-undeclared.patch	\
+  distro/patches/guile-1.8-cpp-4.5.patch		\
+  distro/patches/m4-gets-undeclared.patch		\
+  distro/patches/m4-readlink-EINVAL.patch		\
+  distro/patches/m4-s_isdir.patch			\
+  distro/patches/make-impure-dirs.patch			\
+  distro/patches/findutils-absolute-paths.patch		\
+  distro/patches/readline-link-ncurses.patch		\
   distro/patches/tar-gets-undeclared.patch
 
 nobase_nodist_guilemodule_DATA = $(GOBJECTS)