summary refs log tree commit diff
path: root/build-aux/hydra
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-27 09:48:16 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-08 17:48:33 +0200
commit351f384e57939005b25fa976952e3a0e08785893 (patch)
tree4e318e68b71708317633afb5ecdcd4b717aaaf53 /build-aux/hydra
parenta1ec7540be9b30593f5e83e36a0e83b1bcf337f1 (diff)
downloadguix-351f384e57939005b25fa976952e3a0e08785893.tar.gz
cuirass: Add job specs for the modular Guix.
* build-aux/cuirass/guix-modular.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
Diffstat (limited to 'build-aux/hydra')
-rw-r--r--build-aux/hydra/guix-modular.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/build-aux/hydra/guix-modular.scm b/build-aux/hydra/guix-modular.scm
index bdbb2fa8d5..b6ba7040ba 100644
--- a/build-aux/hydra/guix-modular.scm
+++ b/build-aux/hydra/guix-modular.scm
@@ -86,15 +86,16 @@ for SYSTEM.  Use VERSION as the version identifier."
        (list (%current-system)))))
 
   (define guix-checkout
-    (assq-ref arguments 'guix))
+    (or (assq-ref arguments 'guix)                ;Hydra on hydra
+        (assq-ref arguments 'guix-modular)))      ;Cuirass on berlin
 
   (define version
     (or (assq-ref guix-checkout 'revision)
         "0.unknown"))
 
   (let ((file (assq-ref guix-checkout 'file-name)))
-    (format (current-error-port) "using checkout ~s (~s)~%"
-            guix-checkout file)
+    (format (current-error-port) "using checkout ~s (~s; arguments: ~s)~%"
+            guix-checkout file arguments)
 
     (map (lambda (system)
            (let ((name (string->symbol