summary refs log tree commit diff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-10 00:31:31 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-10 00:35:27 +0200
commita94546ecc46b15d68764a8d3c859315c18010bb4 (patch)
treeb414fc8633a40299316e68cfca18098024988747 /build-aux
parented09bb11cdd3454c00caf10615fac3cdd1791d55 (diff)
downloadguix-a94546ecc46b15d68764a8d3c859315c18010bb4.tar.gz
gnu: linux-libre: Add i686 and x86_64 full-blown configs.
Thanks to Jason Self <jself@gnu.org> for the kernel configs.

* gnu/packages/linux.scm (kernel-config): New procedure.
  (linux-libre)[build-phase]: Copy it to .config.  Reduce the list of
  things appended to .config.
  [native-inputs]: Add "kconfig" input.
* gnu/packages/linux-libre-i686.conf,
  gnu/packages/linux-libre-x86_64.conf: New files, from
  <http://jxself.org/x86-32.txt> and <http://jxself.org/x86-64.txt>.
* Makefile.am (KCONFIGS): New variable.
  (nobase_dist_guilemodule_DATA): Add it.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/hydra/demo-os.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/build-aux/hydra/demo-os.scm b/build-aux/hydra/demo-os.scm
index 3276b8e2bf..43baa391e3 100644
--- a/build-aux/hydra/demo-os.scm
+++ b/build-aux/hydra/demo-os.scm
@@ -26,6 +26,7 @@
 
              (gnu packages xorg)
              (gnu packages avahi)
+             (gnu packages linux)
 
              (gnu services networking)
              (gnu services avahi)
@@ -47,7 +48,8 @@
           (device "dummy")
           (type "dummy"))
         ;; %fuse-control-file-system   ; needs fuse.ko
-        %binary-format-file-system))
+        ;; %binary-format-file-system  ; needs binfmt.ko
+        ))
 
  (users (list (user-account
                (name "guest")
@@ -83,4 +85,4 @@ You can log in as 'guest' or 'root' with no password.
   ;; Explicitly allow for empty passwords.
   (base-pam-services #:allow-empty-passwords? #t))
 
- (packages (cons* xterm avahi %base-packages)))
+ (packages (cons* strace xterm avahi %base-packages)))