summary refs log tree commit diff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-13 17:30:15 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-13 17:33:38 +0100
commitf292c5019111f92b6850afdca4b59f4146b9be3b (patch)
treef1bed037a60b6d4e47ae42c27e1882ee34ea2c26 /build-aux
parent24fb0dc0ab34ebb49509a3d5b4d84d8488670807 (diff)
downloadguix-f292c5019111f92b6850afdca4b59f4146b9be3b.tar.gz
maint: Add 'etc/release-manifest.scm'.
* etc/release-manifest.scm: New file.
* gnu/ci.scm (%cross-targets): Export.
* build-aux/check-available-binaries.scm: Remove.
* Makefile.am (EXTRA_DIST): Add 'etc/release-manifest.scm' and remove
'build-aux/check-available-binaries.scm'.
(assert-binaries-available): Rewrite using 'guix weather -m'.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/check-available-binaries.scm78
1 files changed, 0 insertions, 78 deletions
diff --git a/build-aux/check-available-binaries.scm b/build-aux/check-available-binaries.scm
deleted file mode 100644
index f39874ab71..0000000000
--- a/build-aux/check-available-binaries.scm
+++ /dev/null
@@ -1,78 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-;;;
-;;; Check whether important binaries are available.
-;;;
-
-(use-modules (guix store)
-             (guix grafts)
-             (guix packages)
-             (guix derivations)
-             (gnu packages)
-             (gnu packages certs)
-             (gnu packages emacs)
-             (gnu packages make-bootstrap)
-             (gnu packages ssh)
-             (srfi srfi-1)
-             (srfi srfi-26)
-             (ice-9 format))
-
-(define (packages-for-system system)
-  "Return the list of packages to check for SYSTEM."
-  (let ((base (list %bootstrap-tarballs emacs nss-certs openssh)))
-    ;; On Intel systems, make sure key packages proposed by the installer are
-    ;; available.
-    (if (member system '("x86_64-linux" "i686-linux"))
-        (append (map specification->package
-                     '("xfce" "gnome" "mate" "enlightenment"
-                       "openbox" "awesome" "i3-wm" "ratpoison"
-                       "network-manager-applet" "xlockmore"
-                       "linux-libre" "grub-hybrid" "xorg-server"
-                       "libreoffice"
-                       ;; FIXME: Add IceCat when Rust is available on i686.
-                       #;"icecat"))
-                base)
-        base)))
-
-(with-store store
-  (parameterize ((%graft? #f))
-    (let* ((native (append-map (lambda (system)
-                                 (map (cut package-derivation store <> system)
-                                      (packages-for-system system)))
-                               %hydra-supported-systems))
-           (cross  (map (cut package-cross-derivation store
-                             %bootstrap-tarballs <>)
-                        '("mips64el-linux-gnu"
-                          "arm-linux-gnueabihf")))
-           (total  (append native cross)))
-
-      (set-build-options store
-                         #:use-substitutes? #t
-                         #:substitute-urls %default-substitute-urls)
-      (let* ((total     (map derivation->output-path total))
-             (available (substitutable-paths store total))
-             (missing   (lset-difference string=? total available)))
-        (if (null? missing)
-            (format (current-error-port)
-                    "~a packages found substitutable on~{ ~a~}~%"
-                    (length total) %hydra-supported-systems)
-            (format (current-error-port)
-                    "~a packages are not substitutable:~%~{  ~a~%~}~%"
-                    (length missing) missing))
-        (exit (null? missing))))))