summary refs log tree commit diff
path: root/config-daemon.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-05 17:48:23 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-07 23:47:22 +0100
commitf997137d0e2eba27bb1e2b282ee19ea474c41e12 (patch)
tree3a188ef54d7157cabc5c0b432e92b3bcabad03fd /config-daemon.ac
parent29a686688674dc875775305312513405fa396a06 (diff)
downloadguix-f997137d0e2eba27bb1e2b282ee19ea474c41e12.tar.gz
daemon: Make libbz2 an optional dependency.
* config-daemon.ac: Don't bail out when libbz2 is missing.  Define
'HAVE_LIBBZ2' Automake conditional.
* nix/libstore/build.cc: Wrap relevant bits in '#if HAVE_BZLIB_H'.
* nix/libstore/globals.cc (Settings::Settings): 'logCompression'
defaults to COMPRESSION_GZIP when HAVE_BZLIB_H is false.
* nix/libstore/globals.hh (CompressionType): Make 'COMPRESSION_BZIP2'
conditional on HAVE_BZLIB_H.
* nix/local.mk (guix_register_LDADD, guix_daemon_LDADD): Add -lbz2 only
when HAVE_LIBBZ2.
* nix/nix-daemon/guix-daemon.cc (parse_opt): Ignore "bzip2" when not
HAVE_BZLIB_H.
Diffstat (limited to 'config-daemon.ac')
-rw-r--r--config-daemon.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/config-daemon.ac b/config-daemon.ac
index 59f6f2713f..80d84cbdbc 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -24,11 +24,12 @@ if test "x$guix_build_daemon" = "xyes"; then
   AC_CHECK_HEADERS([zlib.h], [true],
     [AC_MSG_ERROR([Guix requires zlib.  See http://www.zlib.net/.])])
 
-  dnl Look for libbz2, a required dependency.
-  AC_CHECK_LIB([bz2], [BZ2_bzWriteOpen], [true],
-    [AC_MSG_ERROR([Guix requires libbz2, which is part of bzip2.  See http://www.bzip.org/.])])
-  AC_CHECK_HEADERS([bzlib.h], [true],
-    [AC_MSG_ERROR([Guix requires libbz2, which is part of bzip2.  See http://www.bzip.org/.])])
+  dnl Look for libbz2, an optional dependency.
+  AC_CHECK_LIB([bz2], [BZ2_bzWriteOpen], [HAVE_LIBBZ2=yes], [HAVE_LIBBZ2=no])
+  if test "x$HAVE_LIBBZ2" = xyes; then
+    AC_CHECK_HEADERS([bzlib.h])
+    HAVE_LIBBZ2="$ac_cv_header_bzlib_h"
+  fi
 
   dnl Look for SQLite, a required dependency.
   PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= 3.6.19])
@@ -169,6 +170,7 @@ if test "x$guix_build_daemon" = "xyes"; then
     [chmod +x nix/scripts/offload])
 fi
 
+AM_CONDITIONAL([HAVE_LIBBZ2], [test "x$HAVE_LIBBZ2" = "xyes"])
 AM_CONDITIONAL([BUILD_DAEMON], [test "x$guix_build_daemon" = "xyes"])
 AM_CONDITIONAL([BUILD_DAEMON_OFFLOAD],			\
   [test "x$guix_build_daemon" = "xyes"			\