summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-11-23 10:56:49 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:21 +0100
commit7d328e341a5caca995b6c18c38ae2e9ee07f7b7e (patch)
tree3d26bc1fecaaec5c341d03734a3528b266de9969 /configure.ac
parent9b9a5e3283168463545588f83748bb36411e68fe (diff)
downloadguix-7d328e341a5caca995b6c18c38ae2e9ee07f7b7e.tar.gz
configure: Disable installer build by default.
Only build installer if "--enable-installer" is passed. In that case only, the
support for Guile-newt becomes mandatory.

* configure.ac: Add --enable-installer argument. Export ENABLE_INSTALLER
conditional according to the argument value.
* gnu/local.mk (GNU_SYSTEM_MODULES): Remove installer modules and build them
only if ENABLE_INSTALLER is set.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83a9b87d77..5d70de4beb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,9 +137,18 @@ fi
 
 dnl Guile-newt is used by the graphical installer.
 GUILE_MODULE_AVAILABLE([have_guile_newt], [(newt)])
+
+AC_ARG_ENABLE([installer],
+    AS_HELP_STRING([--enable-installer], [Build the graphical installer sources.]))
+
+AS_IF([test "x$enable_installer" = "xyes"], [
 if test "x$have_guile_newt" != "xyes"; then
   AC_MSG_ERROR([Guile-newt could not be found; please install it.])
 fi
+])
+
+AM_CONDITIONAL([ENABLE_INSTALLER],
+  [test "x$enable_installer" = "xyes"])
 
 dnl Make sure we have a full-fledged Guile.
 GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])